BASTAS - Be A Santa To A Senior - Project

running on my linux server in /var/www/html/BASTAS/

All files and folders are in that sub folder.

And there is another directory in /var/www/html/BASTAS/ called BASTAS? or is there a .git file at /var/www/html/BASTAS/.git?

I guess what I am trying to figure out is if your web server is running the root of the page at /var/www/html/BASTAS/ or some other directory above or below that. If so, then the links in the home.html file will not be able to find the correct files which could cause some of what you are seeing. Something that is strange is that I don’t see the word “Login” anywhere in Home.html or any other file. Maybe your work-space has changed from the repo’s HEAD?

@daniel_ferguson @mynameiscow @tbaugh @Lopezb29

I have started adding tasks to the kanboard at http://70.255.89.141/kanboard/ so we can track our progress a bit on getting things done.

You’ll see vertical lanes that have tasks under them. You may have your name assigned to some already, or may not. If you want to snag one, then please assign it to yourself, and move it to the appropriate lane for it’s current stage.

It should be pretty self explanatory.

If you don’t have login info, or don’t remember you login info, let me know and I can reset your login, or create one for you. I have quite a few tasks in the Code Review column. So if someone would take a look at those, I would appreciate it. I promise my code is pretty aweful in general, so help me out.

There are quite a few more tasks that need to be added. I am trying to keep them in somewhat small but testable pieces. I can look at Chris’s code, and probably won’t be able to add much, but a good learning experience for me.

If you guys have questions, let me know.

I’m not sure but All of the files from the repo (which I have done a git clone on, are simply copied over into the /var/www/html/BASTAS folder (while /var/www/html is where everything lives when I just go to localhost in my browser). I made sure I was in BASTAS, which is where the package.json file is, along with home.html and the others, then I did

npm install

And let the Node Package Manager do its thing. My actual dev / git repo is in a different location from my web-server, and intentionally so.

Updated DEV_README with new instructions and made some changes to the npm install / start commands. You should now be able to run ‘npm start’ from the project directory and get a temporary sever started on your machine for development purposes. Deployment to a live server should be as easy as dropping all the files into the web application directory. Let me know if anyone has any more difficulty running project.

I’m still working on getting a mockup of how we will call the php services from inside angular, but I will post a solution here when I have one.

CC: @bmcgonag, @tbaugh, @mynameiscow, @lbblug

I won’t be able to attend LUG meetings with the new schedule. But we’ll keep the BASTAS server online until the project is over after the 2015 holidays.

Best wishes on your future activities.

/MM

Ran thought this, and the Legacy Node stuff seems to have done the trick. Ran all the way through first step of install.

@daniel_ferguson I got the nom stuff working, but still don’t see your angular view showing up when I go to the page. The page resolves fine using the nom address, but no angular stuff. Can take a little time this week so you can go over what you have vs. what I have in my repo, and make sure they are up to date? I did a git pull two days ago, and uploaded some new stuff today.

I see the div you made with ng-app, but nothing shows up there.

Thanks,

@daniel_ferguson if you’ll email me your code for the hm.html file, I’ll diff it against my own, and if they are different I’ll update mine. That way I don’t scrap whatever you’ve got in the file in github.

@mem0lnx I think I missed something . To which schedule are you referring?

@mynameiscow - I sent out an email detailing that starting with the August meeting we would be trying Thursday evenings for the meeting time starting at 6:30 PM. I’ll send out a calendar invite too. I think that must be a hard day for Michael to make.

@bmcgonag
I’ve committed a newer version of the batch importer script to the github repository. The merge seems to have sucked in a bunch of other stuff that I didn’t touch, I hope I didn’t screw up the repo. Please check that when you have a chance, I can go back a commit and re commit the script.

The batch script can now make direct insertions into tables. At the moment the commands are in place simply to test this. The only remaining item now is to construct the specific commands which utilize the store procedures in the database.

I am uploading an image of what the current BASTAS Ornament looks like. It is the ornament that we hang on the trees, so an individual can take the ornament and buy the gifts. What is on the ornament is the index number (in the past it has been the route # plus a sequential number that follows. i.e. 50-1). It has the first name, and two or maybe three gift requests. It also contains the collection date. I will also upload an example of what the back of the ornament looks like, which is a brief description of what to do with the gifts after purchasing them.

1 Like

@bmcgonag

I’ve tried to run through the server setup on my laptop (using the latest version in git). install.html claims to have successfully created the database and tables, but I do not see the database when I peak by hand. It also gets stuck at the step when it tries to create an administrator. Any thoughts?

C

@bmcgonag

OK, problem solved. I had forgotten to configure PHP in Apache. Now I have the db created, but I’m getting a syntax error on line 314 of CreateTables.php.

if ($make->query($createTableNotes) === TRUE) {
echo “Notes table created successfully!
”;
} else { echo "Error creating Notes table: " . $make->error;
echo “
”;
}

The error is “unexpected ‘->’ …”

C

Not sure why it’s failing on Notes. I don’t recall changing anything about the Notes table. I’ll give it a try when i’m back home this weekend, and see if I see anything. From the code you sent, the -> appears to be in the right place.

Basically each query if formed, and assigned to a variable to create the table, then $make is just a variable holding the ‘connection settings’.

So, without looking at the $createTableNotes, I can’t tell if I messed something up during my changing and tinkering things around in there. Glad you got the rest working, but not sure why it didn’t give you a proper error when php wasn’t setup on apache. That’s odd.

That’s interesting. In looking at the repo, your line 314, and the one I just pulled don’t match. My createNotes is way up in the teens or 20s, and 314 is createActivityLog. Have you pulled the latest repo?

@mynameiscow I updated the repo. I found a typo on line 312. Still affects the createActivityLog table, but should help with getting that to continue through.

@bmcgonag I think I copied the wrong section of code (it was late). I still have an error on line 314, which , yes, has to do with createActivityLog. Did you push your changes up to github?

It looks like the last commit was on the 10th.

C

@bmcgonag I see the problem … rather obvious. There is a missing ‘$’ before make on line 314. There were also a couple of typos ( a missing ‘;’ and a ‘-?’ instead of ‘->’ ). I can push these up to the github repo if you haven’t already fixed them, but it will probably be easier to avoid the merge if you have these changes already in your local repo.

C