Server Migration

For the past couple of weeks, I’ve noticed my personal home server (Ubuntu 14.0 that started as a Ubuntu 11.04 originally) has been dying.

I initially thought it was brought on by an update that was buggy, but have since come to the conclusion that the hardware is finally crapping out on me.

This is a Core duo chip I bought many years ago, in a box I built from parts, and it has done well for me.

It was a bit limited in many respects, as it was 32 bit, and limited to 4 GB RAM, but I had about 9 TB drive space on it, and used it for my owncloud server, and various other web based applications.

Needless to say, i didn’t want to just lose it, and not have something ready to take it’s place.

I started looking at my alternatives, and decided that I would just create a new one. Now, when I say new, I mean a machine that has a slightly newer chip, and more RAM.

So, I’ve got a machine with a Core 2 Duo, 64 bit, and 8 GB RAM. so basically doubled everything. HA!

I started trying to install the latest Ubuntu 14.04.2 LTS, and immediately found that the live USB would boot , run great, and install to the HDD, but after every install, on reboot, I found that it would give me a ‘Gave Up Waiting’ message and never boot.

I read on forums, and dug around online about this for hours, and never found a real solution. I did try setting the BIOS back to ‘Legacy’ hardware for the drive (though it’s a fairly new 1 TB SATA drive, then ran the install again.

Well, it booted when I did that, but I coudln’t get the Mouse or any of 3 keyboards to function. So, back to square 1 with that one.

I tried an older 14.04 (no .X) version, and still no joy.

I finally tried an Elementary Luna install just to see what would happen. I know they use older (stable) Kernels. Worked like a charm. Not really what Elementary was made for, but I’m giving it a go.

So far, I’ve:

  • Installed LAMP Server
  • Configured OpenSSH server
  • Installed OpenSSL and setup a self-signed Cert
  • Installed and configured Neo-Router server and client
  • Installed the latest OwnCloud server and got it syncing.

I’ve still got to:

  • Install Wallabag (a self-hosted Read It Later type server)
  • Install KanBoard (a self-hosted card based system for tracking tasks)
  • Install Plex media server

So, I’m more than half way there. It was a good weekend of tech, learning, and trial and error.